Forum OpenACS Q&A: Install Software link from Site-wide Admin not working?


How do I install new packages from the Site-wide Admin page (/acs-admin/install/)? The link goes to buton that page there is only a link to 5.5 which has no packages listed. I tried 5.4 but that came back not found.

There are a few comments on that page referencing to CVS - is that the preferred way to download new packages? It would be great if somebody could point me to a page describing the current recommended practice.


Or even just tell me how to do it. 😊
Posted by Dave Bauer on

If the repository is broken, CVS will work :) I will see if I can figure out why it's broken for now. It should be working and have channels for 5.2,5.3,5.4 available.

Note that only packges tagged by the maintainer will show up in the repository, so not everything, but all the dotlrn packages at least along with acs-core of course should show up.

Dave saves the day as usual. Thanks Dave!
Many thanks Gustaf!


Also, referring to the link Gustaf provided----

Gustaf:Thanks for kicking the repository into shape!

As Dave mentioned, there are quite a number of packages that don't show up due to tagging, and many of them are ones that I want to install. Also, although I can now get a list of packages, every one I've tried to install (calendar, photo album, faq, and I think one or two others) has bombed out with a "invalid command name "<package>:after_install"

There were a few (minor) reasons why I didn't want to deal with CVS, but it looks like that's the route I'll go.

Dear Matthew,

i checked the situation: most likely, you have
an oacs 5.4 installation. For 5.4, the files from the content repository tagged by "openacs-5-4-compat" are presented via the "install/upgrade from repository". Currently, we have the following situation:

- the files from acs-core show up correctly and can be installed correctly via upgrade/install from repo

- the application packages (assessment, attachments, bm-portlet, bulk-mail, calendar, calendar-portlet, ...) show as well up, but they can't be installed. For these files, for some reason, only the .info files are tagged with "openacs-5-4-compat".

This is really bad, since the apm-builder finds the tagged .info files and builds its apm-files from it. It would be much better not tagging any files than just tagging the .info files. I have no idea who tagged the .info file for which purpose, but this is certainly wrong. The problem that you saw with the "after install callback" happens, since the installer downloaded the more or less empty .apm file (containing just the .info file), extracts it successfully, installs all its files (just the .info file) and finds the callback in the .info file and tries to execute it.

What should be done is to tag the packages in the actual dotlrn release (based on 5.4) with "openacs-5-4-compat". Then, after the next nightly respository build, upgrade from repository will work again for 5.4 installations.

It looks to me as if this is just a problem for 5.4, head or older versions look ok.

Posted by Don Baccus on
I've tagged dotlrn-2-4-1-final as openacs-5-4-compat so hopefully the repository will rebuild properly now.

Post here if it doesn't happen soon, please.

Thanks for figuring this out, Gustaf ... I have no idea why only the .info files got tagged for the 2.4 release.