Forum OpenACS Q&A: Problems with SDM - CVS Source Repository

I am having problems with the source code repository in the
SDM in OpenACS 3.2.5. I created some test files in the CVS
repository on the local server, and then created a test package in
the SDM. I put in the correct CVS path ("edit cvs for this package"
under Administration) and loaded the CVS files ("get new source
from CVS" on the Source Repository page). However, I can only
see directories, not individual files, in the list on the Source
Repository page produced by package-repository.tcl.

I have checked the server log and do not see any obvious errors
(after correcting some initial permissions problems). I have also
confirmed that the files are being checked out and put into the
OpenACS data directory (/servers/openacs/data/sdm-source).

Please forgive me if this is a stupid/novice question as I am fairly
new to both CVS and OpenACS. I did check the forums and
documentation but didn't find anything relevant to this problem.
I'm running on RedHat Linux 7.0 if it makes any difference.

Thanks - Julie

Posted by Jerry Asher on
I submitted a patch to fix this with "" Basically, I think what you are doing would work if you set the glob file pattern to a single asterisk. But I think that's not the right default behavior and so I've forced the listing function to check the glob file pattern. If it's an empty string (meaning "please don't show me anything but directories in my cvs repository"), it changes the glob file pattern to "*", meaning "please do the right thing."

You may also wish to check out, which lets you give a name in the ACS to a CVS repository that is not the actual name of the CVS repository. As in showing "AOLserver Postgres Driver" for the name of a repository when the actual CVS name is probably something more like "pg-driver".

Posted by Julie Bernstein on
Thanks very much, Jerry. Setting the "File Regexp Patterns"
under "edit repository properties" to "*" did indeed do the trick.

It would be great if this entire module were better-documented,
because truth be told I really didn't understand what values I was
supposed to enter.

I will check out your patches as well now that is
back on-line. Thanks again - Julie