Forum OpenACS Q&A: LD_LIBRARY_PATH considered harmful

Posted by Jonathan Marsden on
You found it. You just didn't realize what you found!

The alteration in LD_LIBRARY_PATH is almost certainly the cause of your problem. Normal Linux boxes do not change that setting. Those who do play around with it need to understand exactly what it does...

I'd say try (as root)

  bin/nsd76 -u nsadmin -g web -t service.tcl

Or if you truly need the Oracle libs too, try

  export LD_LIBRARY_PATH=/ora8/m01/app/oracle/product/8.1.6/lib:/lib:/usr/lib
  bin/nsd76 -u nsadmin -g web -t service.tcl

Assuming that things then work fine, you need to work out where the LD_LIBRARY_PATH is being set to *just* /usr/lib/pgsql and either get rid of that setting, or else set it to a more reasonable value that includes /lib and /usr/lib as well.

Check /root/.bash_profile for one possible place where it might be being set.

You really should not have to add /usr/lib/pgsql to your library path like this. Whose install instructions for PG or AOLserver or OpenACS told you to modify root's LD_LIBRARY_PATH to just /usr/lib/pgsql? Those instructions should probably be corrected.