Forum OpenACS Development: Response to OpenACS 4 fails to install

Posted by Jonathan Marsden on

I tried an OpenACS4 install myself for the first time just now.

The PG locale stuff worked for me following my own instructions (this was RH 7.1 and the PG 7.1.3 RPMs); that is, make sure the initdb (done the first time you start postgresql and there is no pre-existing database) happens under LANG=C. Are you sure when you tried it you didn't have an existing older PG database present?

However, I now seem to have a more interesting issue... after installing PG 7.1.3, aolserver-3.3.1+ad13 and aolserver-nsxml and libxml2 2.4.1 and libxslt 1.0.1 (all from RPMs), I:

  1. Update openacs4 from CVS, then copy the files over to /var/lib/aolserver/servers/openacs4. rm -rf packages/acs-subsite since it isn't 'PORTED' yet, and seems to give an error about a missing file if you leave it in there.
  2. Edit /etc/aolserver/nsd.tcl to use a PG db and username of openacs4, and to expect the pageroot to be .../openacs4 rather than .../defaultacs.
  3. Fire up aolserver, point a browser at port 8000.
  4. Edit one more time and reboot to get rid of a warning about teh Fancy parser, though actually it *was* enabled, just in a different way from the way the installer seems to check... convert siggested .ini settings to .tcl (incidentally, shouldn't the installer offer both, or offer the .tcl way instead of .ini??), edit, restart aolserver.
  5. No warnings this time, select Next, ACS kernel installed fine, select Next again.
  6. Lost more installing happens, all looks fine, then it says it is 'Completing install sequence'. A few more commands echo, then nothing happens.

The log shows a referential integrity issue, followed by a problem writing a NULL into a NOT NULL field:

[24/Aug/2001:22:19:57][13925.4101][-conn0-] Error: Error sourcing /var/lib/aolserver/servers/openacs4/packages/acs-bootstrap-installer/installer/packages-install.tcl:
psql:acs-install.sql:196: ERROR:  apm_packages_package_key_fk referential integrity violation - key referenced from apm_packages not found in apm_package_types
psql:acs-install.sql:203: ERROR:  ExecAppend: Fail to add null value in not null attribute object_id

    invoked from within
"db_source_sql_file -callback apm_ns_write_callback acs-install.sql"
    invoked from within
"if { ![ad_acs_admin_node] } {
    ns_write "  <p><li> Completing Install sequence.<p>
    cd [file join [acs_root_dir] packages..."
    (file "/var/lib/aolserver/servers/openacs4/packages/acs-bootstrap-installer/installer/packages-install.tcl" line 34)
    invoked from within
"source $__file "

Repeated visits to http://myhostname:8000 just get me the same thing, I can't do anything useful with the installation at all.