Forum OpenACS Development: Re: BSD installer: FreeBSD port

Posted by Tyge Cawthon on
Aldert - Thanks for the help.

Here are the changes I did and the order. Please note: I rebooted between each change. It was not until all the changes where done that OpenACS worked on port 8000.

1. update the permissions
chmod -R 755 /var/lib/aolserver/service0/etc/daemontools
chmod -R 755 /service/service0

2. changed shell to bash for root, postgres, serviceo
chsh -s /usr/local/bin/bash root
chsh -s /usr/local/bin/bash service0
chsh -s /usr/local/bin/bash postgres

3. added the .profile file and corrected command line:export PS1="<\u-\W>" for:
a. root
b. postgres
c. service0

(note: 4-5 done together before last reboot)
4. updated the /etc/rc.conf by adding (all one line):
ldconfig_paths="/usr/lib/compat /usr/X11R6/lib /usr/local/lib /usr/local/aolserver/lib

5. add this to the root .profile (all one line):
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pgsql/lib:/usr/local/aolserver/lib

Openacs worked!!!.... NICE JOB EVERYONE!!!
I than updated the daemontools/run and
/var/lib/aolserver/service0/etc/config.tcl to use
post 80 and 443

Everything works again....
Everyone - Have A Safe and Happy Holiday!!