Forum OpenACS Q&A: Postmaster is eating my CPU

Posted by James Thornton on
Postmaster is eating my CPU -- see ps and top output at (it wrapped too much when I tried to post it to the bboard).

As you can see from the ps output, there are several INSERT statements -- these return after restarting Postgres and even rebooting the system. I checked the system log for that server, and there are only ~30 INSERTS over the last ~12 hours (all INSERT into referer_log). Futhermore, I haven't been running any INSERT statements from psql, and no one else has access to this system.

Yesterday, I ran "vacuum analyze" for the first time in a long time -- could that have caused this situation?

Posted by Don Baccus on
This is very strange ... my guess is that for some reason a lock is being held persistently and your processes are spinning on it.  This should never (cough) happen.

This is one for the PG hackers group, I think - Tom Lane's more likely
to be able to give you help here than any of us.

Posted by good bye on
did you ever get any resolution on this? the same thing just
happened to me today. however, it looks like a SELECT is
causing postgres to spin. the only thing i really did to the
database in the past 24 hours is rebuild some views. and, the
site goes live tomorrow. perfect timing! 😟
Posted by good bye on
I figured this out in my case. I had altered a table by renaming a
column. The view that my page was using used that particular
column to determine what rows were a part of the view... Which
ended up causing some serious weirdness. so, just a word of
warning: dont do what i did.