Forum OpenACS Q&A: invalid command name "encoding"?

I'm getting the next error, when I did an upgrade to an existing site, the strange thing is that in some pages I got the error and in others not, for example I can see the news/index pages but when I tried to suggest a news item I have the error, the same when I try to login, etc.

I'm using openacs 3.2.5, pg7.1.2 and tried with aolserver3.3+ad13 and aolserver3.3+ad12 running nsd76

my config files is a copy the sample posted here with the appropiate modifications.

[05/Sep/2001:09:35:39][19413.3076][-conn0-] Notice: ns_getform using 
encoding  for charset iso-8859-1
[05/Sep/2001:09:35:39][19413.3076][-conn0-] Error: invalid command 
name "encoding"
invalid command name "encoding"
    while executing
"encoding convertfrom $encoding $value"
    invoked from within
"set newvalue [encoding convertfrom $encoding $value]..."
    ("for" body line 6)
    invoked from within
"for {set i 0} {$i < $n} {incr i} {
            set key [ns_set key $_ns_form $i]
            set value [ns_set value $_ns_form $i]

            set value [ns_set valu ..."
    invoked from within
"if {[empty_string_p $cached]} {
        # loop calling encoding convertfrom here over _ns_form

        set newform [ns_set create [ns_set name $_ns_form]]
        set en ..."
    (procedure "ns_getform" line 66)
    invoked from within
"ns_getform"
    invoked from within
"if { [ns_getform] == "" } {
        if $error_if_not_found_p {
            uplevel {
                ns_returnerror 500 "Missing form data"
                return
            }
        } else {
            return ..."
    (procedure "set_the_usual_form_variables" line 2)
    invoked from within
"set_the_usual_form_variables 0"
    (file "/web/lectario/www/news/post-new.tcl" line 23)
    invoked from within
"source $script"
    invoked from within
"if ![file exists $script] {
                ns_returnnotfound $conn
        } else {
                source $script
        }"
    (procedure "ns_sourceproc" line 3)
    invoked from within
"ns_sourceproc cns0 {}"
Collapse
Posted by Jonathan Marsden on
Rocael, the encoding command is a Tcl 8.x command and is not present in Tcl 7.6, as far as I know.

That might explain your problems?  Try switching to nsd8x and see what happens :-)