Forum OpenACS Q&A: Response to OpenACS 4 on Mac OS X (and Darwin) HOWTO now available


You wrote "Mac OS X (preferably 10.0.4 or later)" for the requirements.
I tried installing it on Mac OS X 10.1 5G48 (which classifies as 'later' for me), and it doesn't work. After messing around with some makefiles of aolserver (adding -flat_namespace), I got everything to work, except PostgreSQL. It compiles fine (using --without-shared or with shared when adding -flat_namespace, I tried both), but I can't create new databases:

% createdb test
pqReadData() -- backend closed the channel unexpectedly.
        This probably means the backend terminated abnormally
        before or while processing the request.
connection to server was lost
createdb: database creation failed

I'm able to connect to the HTTP-server, but it says it can't connect to the database (since openacs4 doesn't exist). Creating users works fine.
Anybody got a clue? Maybe there's a way to debug it? is down, so I can't check their FAQ - but I guess there's nothing helpful there anyways.

(first post here)