Forum OpenACS Q&A: Response to Can't get pltcl added to postgresql... (rpm's)

I'm sorry you are having trouble installing OpenACS from RPMs on Red Hat 7.1. This looks more like a Postgresql issue than an OpenACS one.

Please try not to randomly install lots of stuff which you think might sort of be related... just follow the instructions, carefully. They work here, and they have been reported to work for some others. I just took the time to clean out OpenACS and PG from my RH 7.1 test machine and tried out the instructions once more... they worked.

By not following the instructions, you diverge from what has been tested, and so increase your risk of difficulties, and make it quite a bit harder for us to help you.

The Postgresql RPMs that you should be using for OpenACS under RH 7.1 are those listed in whichfilesdoineed.html. And no others!

Currently the public version of that document recommends PG 7.1.2-5PGDG RPMs for RH 7.1. I have sucessfully got things to work with PG 7.1.3-1PGDG RPMs also, but I have certainly not tried any PG 7.1.3-4 RPMs and do not know where you got them from. I do not see any such RPMs on the PG FTP site or its mirrors. I see some at Red Hat mirrors, as part of their bleeding edge 'rawhide' code -- I hope you are not trying to use those?? If you are, most likely you should post a bug report to Red Hat Bugzilla about your issues with postgresql-tcl and createlang.

I suggest that you use exactly the RPMs I recommend for RH 7.1, and try again. I suspect things will go a lot more smoothly when you do that. Even if they don't, I will be in a much better position to help you than if you use some other PG RPMs from some other source I know almost nothing about.

Lastly, the RPMs I am using (the official ones from the Postgresql Development Group, aka PGDG) do not mess with LD_LIBRARY_PATH and I suggest that you don't mess with it either, unless you are very sure you fully understand what it does. Those sort of tricks should not be needed if you use the recommended set of RPMs.