Forum OpenACS Q&A: ad_maintain_last_visits error after renaming table...

I just renamed my table studentische_organisationen into
organisationen and now an error message is being shown all the time:

    Error: dbinit: error(localhost::arasis1,ERROR:  Relation
'studentische_organisationen' does not exist
    ): 'update users
    set last_visit = sysdate()
    where user_id = 3'

    Error: ad_maintain_last_visits filter got an error:  Database
operation "dml" failed

    Error: dbinit: db handle limit exceeded: thread already owns 1
handle from pool 'main'

    Error: could not allocate 2 handles from pool "main"
    could not allocate 2 handles from pool "main"
        while executing
    "ns_db gethandle [philg_server_default_pool] 2"
        invoked from within
    "set db_pools [ns_db gethandle [philg_server_default_pool] 2]..."
        (file "/web/server1/www/gc/domain-top.tcl" line 19)
        invoked from within
    "source $script"
        invoked from within
    "if ![file exists $script] {
            ns_returnnotfound $conn
        } else {
            source $script
        (procedure "ns_sourceproc" line 3)
        invoked from within
    "ns_sourceproc cns15 {}"
    Notice: Querying 'select * from referer_log_glob_patterns;'

Does anyone know why and how to stop this error from occuring?

see this thread; it looks like exactly the same problem.
Basically I can't update the users table at all now... It is showing the same error:

Error: dbinit: error(localhost::arasis1,ERROR: Relation 'studentische_organisationen' does not exist ):

I tried to dump the entire database and did:

pg_dumpall -D > /tmp/dumpall.dmp

Then I got this error message:

getTables(): SELECT (for VIEW ec_subsubcategories_augmented) returned NULL oid

SELECT was: SELECT definition as viewdef, (select oid from pg_rewrite where rulename='_RET' || viewname) as view_oid from pg_views where viewname = 'ec_subsubcategories_augmented';

pg_dump failed on arasis, exiting

Anyone familiar with this?

If you don't have a dump from before you renamed the table, you've exceeded my experience.  I would try renaming the table back to see if that unconfuses pg_dump.  After you have the dump you can drop the trigger(s) manually as I described.