Forum OpenACS Q&A: after install temple::adp_parse is undefined

I get the following error after successfully bootstrapping openacs4 (I tried a current checkout and a tarball from about a week ago). I built aolserver from sources (3.3+ad13) and also tried the rpm version and get the same problem with both.
[15/Nov/2001:08:57:12][13046.8197][-conn2-] Error: GET /  invalid
command name "template::adp_parse"
    while executing
"template::adp_parse [file root [ad_conn file]] {}"
    (procedure "adp_parse_ad_conn_file" line 13)
    invoked from within
    ("uplevel" body line 2)
    invoked from within
"uplevel $code"
    invoked from within
"ad_try {
      } ad_script_abort val {
        # do nothing
    invoked from within
"rp_serve_concrete_file [ad_conn file]"
    (procedure "rp_serve_abstract_file" line 60)
    invoked from within
"rp_serve_abstract_file "$root/$path""
    ("uplevel" body line 2)
    invoked from within
"uplevel $code"
    invoked from within
"ad_try {
        rp_serve_abstract_file "$root/$path"
        set tcl_url2file([ad_conn url]) [ad_conn file]
        set tcl_url2path_info([ad_conn url]) [ad_conn path_inf..."

The wierd thing is the function is being defined on startup and is still defined at the end of zz-postload.tcl which I checked via:
namespace eval template {
   ns_log Notice "JCD: postload end: template: [info procs]"
which gives
[15/Nov/2001:08:58:59][13081.1024][-main-] Notice: JCD: postload end: template: adp_init tabstrip request element url get_attribute adp_tag_init set_file get_enclosing_tag adp_level adp_eval adp_abort form paginator forward get_mime_template_extension adp_levels adp_parse adp_puts get_mime_type wizard adp_append_string verify_datasources get_resource_path multirow adp_prepare adp_set_vars parse_directives adp_compile_chunk adp_compile get_datasources register_mime_type query adp_append_code filter get_mime_header_preamble
while a similiar code block in rp_handler gives:
[15/Nov/2001:09:02:46][13096.4101][-conn0-] Notice: JCD: rp_handler: template:

All the non namespace procs are defined throughout. Has anyone seen this before or have any ideas where to look to fix it?

Posted by Jeff Davis on
Here I am answering my own question.  It turns out this is what
happens when you set your  ns/parameters Home variable wrong.

This causes aolserver not to source the scripts in the modules directory which in turn causes it not to generate the interpreter init script
which is what sets up the namespaces in the other threads.