Forum OpenACS Q&A: installation trouble with OpenACS3.5.2 on AOLServer 3.4.2

I installed OpenACS 3.5.2 with AOLServer 3.4.2 on a Slackware Linux 8
box with PostgreSQL 7.1.3.
I can add users to the service,(they end up existing in the users
table) but existing users cannot login.
I get an error on line 67 of .../www/register/user-login.tcl
Log says

Expected boolean got "" instead on line

if{[ad_parameter UsersTableContainsConvertedUsersP] && $converted_p
# We have ...

$converted_p is f for all users, so I tried changing
UsersTableContainsConvertedUsersP in the parameters/<name>.tcl to
both 1 and "t", to no avail.

Any ideas?

ad_parameter returns "" when it can't find the requested key...  have you tried a simple test script (ns_return 200 text/html [ad_parameter UsersTableContainsConvertedUsersP]) to make sure it's what you think it is?  (It should be zero, BTW.)
I noticed you're using nsd 3.4.2...  3.3ad13 is recommended.  You can get it <a href=>here</a>.  I haven't tried it but I'm guessing 3.4 loads its config differently somehow and isn't seeing the definition of UsersTableContainsConvertedUsersP.
It needs to be "1" not "t" (booleans are represented by 0 and 1 in Tcl, just like C, rather than "t" and "f" used by PG).

Best bet is that you're not not sourcing the param file from your nsd.tcl startup script.  You need something like

source "/web/parameters/<name>.tcl"

and make sure you've got the full path, that the user running AOLserver has read privs for the file, etc.

Update on the situation.
I do have indeed a line in the config file saying
source /web/{$server}/parameters/{$server}.tcl
and said file does exist, and it does set the value of the boolean to
1 (the "t" and 0 were let's-see-what-this-button-does things)
There is no mention of the file in the server log though...

I did install aolserver-3.3ad13 and got the very same problem, which is further discouragement...

Just to fill you in on the recent developments.

Any further ideas?

have fun.


Are you following the OpenACS 3.2.5 documentation? We have a pretty detailed Installation Guide, and also a sample nsd.tcl (AOLserver configuration file).

If you followed that guide and can't get it to work, I would appreciate you tell me at what step of the guide did the installation fail.

The documentation (and sample nsd.tcl file) are at in the /doc/ directory of your OpenACS distribution).

Posted by Stan Kaufman on
I'm running AOLServer 3.2-4 with OpenACS 3.2.5 on a Debian woody box and haven't changed things for months, relying on the "if it ain't broke, don't fix it" principle.

However, I do need to upgrade other stuff (like SSH) on this box, and dselect wants to upgrade AOLServer to 3.4.2-1. I know that 3.3-ad13 is the recommended version, but this hasn't been put into a Debian package.

Can the Debian folks out there comment on how they're handling their AOLServer installationS? Are you following the Debian upgrade paths via .debs or are you handling AOLServer by hand? If the former, did you have any problems moving to 3.4.2-1? TIA!

Posted by Dave Bauer on
I compile AOLserver and Postgresql from source. It is not too much hassle because once a web server is going you don't fool around with the database or server softare very much.