Forum OpenACS Q&A: Installing Oracle 8.1.7 on RedHat 7.2

Hi all,
I've been attempting to install Oracle 8.1.7 on Red Hat 7.2.... and it's been tough!
I've found a few useful links on the web: Learning Linux, an article by Bruno Mattarollo at Greenpeace's website and Pawprint and also checked Oracle's Metalink. It seems to me that all the articles cover some of the problems, but none of them seem to cover all of the problems.
Anyway, I was wondering what success people have had? Any pointers to documentation you have found useful?
Posted by Don Baccus on
The main thing you have to do, supposedly, is to run their patch files after installing to deal with glibc version issues.

I've not gotten that far with 8.1.7, but I know others who have (, for example).

I think Oracle's Linux support pretty much sucks, and don't understand why.  It (or a *BSD variant if they decide they don't like Linux) is their best bet vs. MS SQL server + NT.

Posted by Bruno Mattarollo on

Brian, could you tell what has been tough? I installed 3 laptops running 7.2 and Oracle 8.1.7 for development and they all worked like a charm, no problems at all. I did used the laptop pre-selection of packages from RedHat 7.2 and installed some updates, but then using the instructions written in the document I wrote, everything went fine. You just have to make sure that you get the compat-* packages from the RedHat 7.2 CD.

Posted by Daryl Biberdorf on

I've installed Oracle 8i on SuSE 7.1 on two occasions, and, apart from the Java locale issues (Oracle's JRE doesn't like the locale variables set in the environment), it went smoothly. Much more smoothly than my recent install of 8.1.7 on HP-UX, which took me three tries before I managed to set the kernel parameter maxdsize, that Oracle conveniently mentions only on Metalink (a service requiring a support contract). At least SuSE put the Java locale details in the Oracle section of their website.

As another plug for SuSE, they also include a logical volume manager, VERY nice for systems that expect to need more storage over time. Their website also has a pretty good section on various issues related to Oracle on SuSE Linux.

Posted by Brian Fenton on
I think part of the problem was that I had all these conflicting sources of information. Bruno, your article was very clear but made no mention of the glibc-2.1.3-stubs.tar, which a co-worker informed me was needed (is that because your article is aimed at RH 7.1 not 7.2?). Then I found the Learning Linux article mentioned above, which seemed to be derived from your article and also mentioned the stubs, so I decided to use that as a basis. Then my co-worker pointed out all these Metalink articles which gave even more information. I think maybe I'm just suffering from information overload!! (I've just now found this article which is written specifically for Red Hat 7.2 and which claims it's really simple, but makes no mention of the stubs thing either!) I'm also a bit confused about which Java JDK I need - Blackdown or IBM.

The strange thing is that I've installed Oracle many times before, going back to version 7 and it's usually been quite straight-forward.

I think I'll start again from a clean sheet and follow one set of instructions at a time (starting with Bruno's seeing as I've got his attention! 😉 )

I'll be back!
Posted by Janine Ohmer on
I posted this over at web/db, but for completeness' sake I'll post it here too:

You don't actually need to install the compatability libs anymore; Oracle has a patch to make that unnecessary. Here are the steps that worked for me; you can look at Bruno's guide, which is very good, for details on these steps:

  • set LD_ASSUME_KERNEL to 2.2.5 (without this, the installer never comes up)
  • at the first link error, edit $ORACLE_HOME/bin/genclntsh, remove "-z defs", and run the script, then click Retry to continue
  • when you get to the Net8 configurator, stop and install Oracle's glibc patch (glibc-2.1.3-stubs.tar.gz)
  • after the install finishes, run dbassist

It's especially important that you not run dbassist until after you've installed the patch; if you are getting 3113 "end of communication channel" errors while trying to create your database, you have forgotten this step. The voice of experience. :)

Posted by Bruno Mattarollo on

Brian, I didn't needed the stubs. At the time I wrote the document, RedHat 7.2 was not out yet ... but I tryied with it and it worked so I should just replace 7.1 by 7.2 :)

You mention JDK, watch out! You don't need any JDK installed in the machine to install Oracle, since it has it's own ... Maybe some of the problems are related to that ...? I did not install a JDK in the laptops that I had, maybe the problem lies there.

Anyway, I took most of the base of my docs from aD and adapted them to the reality I was seeing ;) so if you have some comments or updates, please let me know ... It's nice to have a good reference document, the problem is that Oracle is so complex and so big that maybe there is no way we can write the document that covers all the possible scenarios :)

Anyway, if you have any problem let me know... I will try to help you as much as I can

Posted by Bruno Mattarollo on

Wow! That's cool! Thanks Janine... I will take a look as soon as I get a blank machine to test with it!

This might be one the best news for all of us that have to install Oracle on Linux machines!

Posted by Brad Duell on
Here's what I finally used to get Oracle 8.1.7 up and running on my 7.2. box:


cd /etc
rm oraInst.loc
mv oratab oratab.old
cd /tmp
rm -rf Orainstall
cd /usr/bin
rm dbhome oraenv coraenv
cd /usr/local/bin
rm dbhome oraenv coraenv

***** FIX THE ENVIRONMENT (./install/oraparam.ini)
cd ./stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux mv jre jre.bak
ln -s /usr/local/jre jre
JRE_MEMORY_OPTIONS=-nojit -ms16m -mx32m

rpm -Uvh compat-libstdc++-6.2-
rpm -Uvh compat-glibc-6.2-
rpm -Uvh compat-egcs-c++-6.2-
rpm -Uvh compat-libs-6.2-3
rpm -Uvh compat-egcs-6.2-
rpm -Uvh compat-egcs-objc-6.2-
rpm -Uvh binutils-

***** RUN INSTALLER (could take a few consecutive times running - i.e. ./runInstaller... screen dump/CTRL-C... ./runInstaller...)

Nearly upon completion, there will be an error stating "Error in invoking target install of makefile $ORACLE_HOME/ctx/lib/", then you copy /tmp/ to $ORACLE_HOME/ctx/lib/ and click on the retry button.

At the end you MIGHT get an error when setting up Net8 configuration. In a shell:
cd /ora8/m01/app/oracle/product/8.1.7/
mv JRE JRE.bak
ln -s /usr/local/jre JRE


Good luck!

Posted by Daryl Biberdorf on
Somewhat off-topic, but related, is the fact that it appears that Oracle has removed Oracle 8i from the list of databases one can
download from Technet. (I'd love to see a contrary report.) That means it is available only in a CD pack (40 USD).
11: Success! (response to 1)
Posted by Brian Fenton on
So I got the install working by following Bruno's instructions (with a few tweaks which I've mailed him with). I think the moral of the story is that there a few approaches to this and that it's not wise to mix 'n' match them, like I initially did! So, I would recommend following Bruno's article step by step.

thanks again to everyone for all the help and support

Posted by Brian Fenton on
Just following up to this...
I mailed my comments and tweaks to Bruno and he recommended I post them here. So here they are (with his responses):

On Mon, 04 Feb 2002, Brian Fenton wrote:

<blockquote> 1. You say:
"Use a text editor to edit the file in the /etc directory. You
can download a prototype of the file". You provide a link
to the file.

But then further down, you say:
"Add the following lines to /etc/"

Some of the values you give for the variables are different from the ones in
the file. For example, the PATH variable has an extra
$ORACLE_HOME/ctx/lib:. in the file. Some of the other variables are
different too.

Also, it might be a good idea to comment out the following line in the file
because it's not needed until after the install:

Yes, the '/etc/' part is not very clear, and I go back several
times over that file. I should limit the mention of the content of it to
only one time!

<blockquote> 2. The next one isn't incorrect, but I stupidly missed it. It might be a
good idea to make it more explicit for stupid readers like me! You correctly
mention that the runInstaller script is located in install/linux on the
cd-rom. However, between that and telling the reader to actually run the
program, you  mention a few other things about the compat files and glibc
etc. - in the mean-time of course, the stupid reader (me!) has forgotten to
go the install/linux directory and instead runs the runInstaller from the
root of the CD. I think it would be helpful to remind again about the path
where you say the following:
"Now we are ready to run the installer of Oracle.
$ ./runInstaller"

True!!! It's a VERY important information that gets lost in the amount of text.
This is very good! Thanks!

<blockquote> 3. This next one was a problem for me. After the Summary screen in the OUI,
the user is asked to run The first thing I noticed is that you tell
the user to do an "su -" to change to root. I think maybe it should be just
an "su" with no "-" because you want to keep the Oracle user's settings.
Otherwise the SID is not set in root's environment etc.

Yes, you are right ... The fact is that I also have the same env set for root
(pointing to but that is only my personal settings and not
the recommended one. This is also a very good comment!

<blockquote> 4. More importantly than that, I found that the script I had was
broken! I got the following error:

Running Oracle8 script...
./ command substitution: line 1: unexpected EOF while looking for
matching `''
./ command substitution: line 2: syntax error: unexpected end of
./ [: !=: unary operator expected

The following environment variables are set as:
<blockquote>    ORACLE_OWNER= oracle
    ORACLE_HOME=  /apps/oracle/product/8.1.7
    ORACLE_SID=  acs817

I fixed this by downloading a correct version of from and editing the ORACLE_HOME value
(twice) in that script.

Of course, you have to keep the Installer window open during all this
downloading and editing!

It's interesting that you never got this error...

I will replace the file then... I am not sure why that one is broken (the
one you get from the site). Damned! I see ... in previous revisions of the docs
I have a link to download a different version of the ... I don't know why
I stupidely deleted that! Thanks!

<blockquote> 5. The next problem I had was a real bummer and it was really a miracle that
got me out of it! It was during the Listener Configuration. I selected No
and suddenly the program hung on me. Thinking it was doing something I left
it for 30 minutes and came back and it was still hanging. I nearly cried
after having gotten so far in the install! For some reason, I decided to
check what processes were running on the machine, one caught my eye: the
listener process. For no reason, I decided to type "lsnrctl stop" (logged in
as oracle) which is the command to stop the listener. Immediately, the
installer program stopped hanging and returned to me! As I said, a miracle.
I was then able to continue on with my install. Whew!

This should go in the troubleshooting section since I had that same problem once
while installing on RedHat 7.1 but I couldn't reproduce it anymore ... Don't know
why ... This also good advice.

Thanks a lot!!!

Posted by Daryl Biberdorf on
Oracle 8i's removal from the download section of Technet appears to have been temporary. It's back now.
Posted by Brian Fenton on
Here's another recommended installation procedure that comes well recommended.
Posted by Peter Marklund on
I just installed Oracle 8.1.7 on RedHat 7.2 and was able to do this by exactly following Brunos instructions at with one crucial addition:

Before running the runInstaller script I downgraded the Binutils:

rpm -Uvh --force --nodeps binutils-

After the Oracle installation was done I upgraded them again:

rpm -Uvh binutils-

Thanks for an excellent document Bruno!

Posted by Janine Ohmer on
An update for anyone else banging their head against this wall - if you apply an upgrade, say, you have to apply the glibc patch I mentioned above again afterwards.  *sigh*
Posted by Andrew Piskorski on
Janine or anybody else, do you know if it works to install the patchset immediately after installing the Oracle 8.1.7 software, before you create a database?

I guess I'll try it, but it'd be nice to know if anyone else has.

Posted by Janine Ohmer on
Yes, it does, in fact that's how I always do it (install the patch before creating a database).

Note that you may have to reinstall the glibc patch after installing patches.  I believe that this just relinks everything, rather than actually replacing patched files, though I admit I can't say for sure.  It hasn't caused me any trouble. If you start getting the dreaded ORA-3113 "end of communication channel" error, there's a good chance that you need to reinstall the glibc patch.