Forum OpenACS Q&A: Response to OpenACS 4 on Mac OS X (and Darwin) HOWTO now available

I spent a couple of hours this evening trying to get ns_xml to compile on Mac OS 10.1

It seems like the linking is what's not working, as Vinod suggested. I tried reinstalling libxml2, and it seemed to install fine. One comment made during the installation seemed interesting:

Libraries have been installed in:

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `DYLD_LIBRARY_PATH' environment 
     during execution

See any operating system documentation about shared libraries 
more information, such as the ld(1) and manual pages.
I experimented with ranlib and libtool, and in fiddled with the Makefile and the .c file in all sorts of configurations, but I still couldn't get it to work. I exported the DYLD_LIBRARY_PATH environmental variable, and tried adding in the -LLIBDIR directive to the compilation process. Either I did it wrong, or there is something else I should be doing...?

Anyone here with more experience with with NetBSD and/or Mac OS 10.1? I'd really appreciate some help!