Forum OpenACS Development: "received fatal signal 11" during ldap login

Request notifications


I am using LDAP for authenticting user on my system. Therefore I installed the auth-ldap package according to the HOW-TO from Malte Sussdorff (

First, I thought everything is working fine. Users from the LDAP Directory could log in and got added to the Openacs user administration. But then I saw that the server restarts after writing "received fatal signal 11" into the serer log. This happens after calling the "get_handle" function, but only in non periodical intervals. So one time it happens after the second login and another time it happens after 100 logins.

I tried to recompile the openldap and nsldap package and I tried to use more recent versions but it happens too.

Maybe someone has a guess what is running wrong or has a tip how to debug this?

Posted by Gustaf Neumann on
i have never used nsladp, therefore i have not seen the problem yet, but maybe you could find my hints still useful.

First of all, be as precise as possible in all bug reports with version numbers of aolserver, tcl, and the involved modules and libraries.

For debugging, i would recommend to recompile all involved C components (including aolserver and tcl) with "-g". Then make sure, your system configuration allows core dumps, and if the server crashes, analyse the core dump with gdb. You will get a backtrace, which might (or might not) give you a hint what happened were.

Note that the error might be in places, where you don't expect it. by googleing around i found many error reports with sig11 ( Or, maybe the library you are using is not thread safe...

Posted by Nathan Lunt on

The URL you posted doesn't show any of the configuration required for ns_ldap's pools in config.tcl, so can you confirm that you've set it up as specified at

My expectation is that ns_ldap will likely crash if there is ever any issue with a connection (I mean anything) to the LDAP server. It's unlikely that it's an issue with openldap, but ns_ldap, itself. Obviously the ns_ldap logging isn't very helpful (the exception handling is dismal), but you may get more beneficial information from openldap, which is probably logging to syslog. One day soon, I'll be fixing up TCLLIB's LDAP package so we can drop ns_ldap completely, but until then it's really going to be a lot of trial and error to determine what ns_ldap doesn't like.


Posted by David Spanberger on
Thank you for your fast response.

To complete my message:

The Server is running as CentOS release 5.2 with Postgresql 8.2.9. from RPM, aolserver 4.5 from source and openacs 5.4.

I'm using openldap-devel-2.3.43. For ns_ldap I tried the version from Malte Sussdorff ( and the newest (from 2002) from sourceforge (v0r8)