Forum OpenACS Q&A: base URL keeps showing port number... (multiple sites single IP)

Request notifications

I think I had run into this before but I can't remember what the solution was and I can find anything in the boards. I am running multiple sites with a master nsd listening on 80 and then passing it on to specific site nsd process on other ports. The problem is when I use relative URL in the code, it reflects the site name with the port which is of course not available outside the firewall. I am not sure if this is a AOLserver config issue or its crept into the database and I need to purge a table.

I greatly appreciate any suggestions!

cheers, Jamie


Are you using nsvhr? If so check this section of the config file for the slave server:

ns_section ns/server/${server}/module/nsunix

if you have ns_param port set, comment it out.

Under your nssock section:

ns_section "ns/server/${server}/module/nssock"
ns_param   location   http://your.internet.domain
where your.internet.domain is the full host plus port you use to contact your webserver.

Thanks, the location parameter was what I was looking for.. which wasn't even in my nsd.tcl file .. when I added that it shows the URL's correctly

thanks again!