Forum OpenACS Q&A: Oracle 10g on x86_64, Debian/Ubuntu vs. Red Hat/SuSe

Has anyone yet tried to install the 64 bit version of Oracle 10g on a Debian or Ubuntu AMD64 (aka, x86_64, either AMD or Intel emt64) system? I am going to try that soon, but this thread seems to point out problems: installing Oracle on Debian AMD64.

Apparently, Debian on AMD64 is currently "pure 64 bit"; they have not yet added the planned "multi arch" support. Their AMD64 How-To talks about adding a 32 bit chroot in order to run 32 bit binaries; that doesn't sound so great, but I'm not sure if that's merely unpleasnt or really awful.

Red Hat and SuSE, on the other hand, are currently doing mixed 32/64 bit systems, with 32 bit stuff in /lib and 64 bit in /lib64. From the thread above, it sounds like the Oracle installer (and possibly some other utilities) are still 32 bit only, and assume a Red Hat style mixed system.

I don't look forward to trying to get this to work, but it sounds like it's really just the Oracle installer that has problems. And AFAIK Oracle's silly Java installer doesn't really do much other than copy files around, so perhaps there is some way to get this to work.

Gee, there isn't a proper deb (or even rpm) package available for Oracle 10g, is there?

Posted by Jade Rubick on
I never thought I would say this, but installing Oracle 10g on RedHat is actually not too bad.

Haven't tried the 64 bit version, though.


I complete failed in my attempts to get Oracle 10g working on Ubuntu AMD64. Ubuntu bug #20025 summarizes what I found.
Posted by bill lan on
Yes i had oracle 10g x86_64 installed on ubuntu feisty fawn 64bit server. It runs perferctly.

oh wait it's 2007, dunno what they had in 2005, but it does work now on the current release of Feisty Fawn. Good luck.

sudo apt-get install gcc libaio1 lesstif2 lesstif2-dev make libc6 libc6-i386 libc6-dev-i386 libstdc++5 lib32stdc++6 lib32z1 ia32-libs