Forum OpenACS Q&A: cant su to postgres

Request notifications

Posted by lee cook on
hi all,

this may seem like a stupid question but its driving me nuts. recently re-installed my debian-sarge system. chucked on apache2 ,php5.0, php5.0-session and postgresql-8.0 using apt-get. Now when I do su - postgres , it dosnt do anything. no errors returned, dosnt even ask for a password. it just stays as whoever im logged in as.

i tried adding the user postgres but it already exsists. which would b be normal i guess.

oh the sources i used for the apt-get was :

deb testing main non-free contrib
deb-src testing main non-free contrib
deb php5 sarge
deb testing vds
deb-src testing vds

i installed this set up only a few days ago and it worked fine. Can anyone point me to where im doing something wrong. Will post more info if needed.

Thanks alot


2: Re: cant su to postgres (response to 1)
Posted by Patrick Giagnocavo on
My guess is that you need to look at the postgres user's shell setting.

Look at /etc/passwd and see if postgres is set to "nologin" or /bin/false as the shell.

If you have a non-valid shell, you cannot log into the account.