Forum OpenACS Q&A: Successful Debian install

16: Successful Debian install (response to 1)
Posted by Ola Hansson on
I find this a bit strange, but, on my second dev box - which is also running Debian Woody - the installation was painless (even more so than installing on RH 7.2, it seems). However, I still can't make it past the listener (Net8) configuration on the box on which I tried before. The boxes both have 256 Mb RAM and I have no idea why it's working on one but not on the other.

Anyway, I have installed on the working machine a few times by now, both on kernel 2.2.20 and on 2.4.18. No problems whatsoever...

There's no need to export LD_ASSUME_KERNEL=2.2.5. Also, the default value for SHMMAX, 32Mb, worked but is probably not enough for a production worthy database.

Here's my miniature Oracle 8.1.7 on Debian Woody guide (based on Tapiwa's RH version):

  1. install stock Debian Woody
  2. If you're re-installing Oracle: cd /etc, rm oraInst.loc, mv oratab oratab.old, cd /usr/local/bin, rm dbhome oraenv coraenv
  3. Follow install instructions in the docs
  4. Download and edit the, changing the ORACLE_HOME twice, from /oracle/u01... to /ora8/m01 and correct the path to awk and sed (the that comes with 8i does not work at all)
  5. When you run this script, make sure you su from user oracle and not su -
  6. After installation, and before you run "dbassist" (before Net8 config is OK too), install the glibc patch as user oracle.
Posted by Andrew Piskorski on
I also innstalled Oracle on Debian 3.0 (Woody), and it all worked.  There's more info in this thread: