Forum OpenACS Forum Summaries: My server response time is slow

Request notifications

Collapse
Posted by Cherifa Bessaidi on
hi!
I'm running ]po[ (project open ) and i released that my server response time is slow or the server is down when more then 10 users are connected to the application.
I had this message in my server log :
"Debug: NO FULLQUERY FOR dbqd..NULL --> using default"
I need help plzz
Collapse
Posted by Richard Hamilton on
I don't use po but I suspect that this error simply tells you that a query doesn't have an entry in the xql file, and so the query that is inline to the code as default is being used.

The xql file is there purely to provide database agnosticism, so if there is no other error, I don't think this is your problem.

Here are some ideas to check to being with:

1) Double check your Aolserver config.tcl (or whatever else you've called it) to make sure that you have sensible and recommended settings for maximum number of threads, concurrent server connections, concurrent db connections, db pools, memory allocated for Aolserver C modules etc. The default config.tcl has settings that need to be changed.

2) If you're using PostgreSQL, make sure you run a vacuum analyse on the db to enable the query planner to accumulate the stats it needs to do the job:

vacuum -zf {db_name}

I don't use Oracle, but if you're using Oracle there is highly likely to be a similar need.

I hope this helps.

Regards
Richard.