Forum OpenACS Q&A: Response to Daemontools problems and nsd not dying

Posted by Lars Pind on
Peter and I were troubleshooting this together this morning, so I'll post the reply here:

1) AOLserver's not being started by any other method. We can start it on the command line with -f, and kill it with C-c, and one or two processes will usually keep running. It's like they're busy. They don't respond to a regular "kill" command, only to "kill -9" (of the ones we've tried).

2) The process looks like to "ps aux", but it doesn't respond to requests to the IP and port number, though it doesn't refuse connections, either.

3) Yes, we do need nsunix, as we're doing virtual hosting on this box. It works perfectly for all other servers on the box.

4) Daemontools requires that you run AOLserver in the foreground, as it pipes the output on stdout to the log process (multilog). If the process moves itself into the background, like it does with -i, daemontools will assume that the process quit, and start a new process, until you have hundreds of them :)

Normally when you stop AOLserver, when you hit C-c, you'll see "stopping", and then about a dozen lines, then "exiting". In this situation, sometimes there's only that one single "stopping" line, sometimes a handful more, but we never see "exiting". So appararantly some of the processes are not repsonding to the signal to kill themselves. After control has returned to the shell, you can still get output from the processes with e.g. scheduled procs being run.

Hope this clarifies things. We're really at a loss here. Btw, it's a rackspace box, and they have their own compilations of Red Hat, which *may* be causing problems. Other bit of info: It's a dual-processor box. Not sure if that could've anything to do with it.

Thanks so much for your help.