Forum OpenACS Development: Re: xowiki error using ns_eval

Posted by Raúl Morales Hidalgo on

After upgrading in our main site the core to 5.4 and xo* packages to newer versions we still have problems with this, the problem now seems to be the one described in the first post of this thread:

invalid database id: "nsdb0"
while executing
"ns_db poolname $handle"

Our system right now:

acs-kernel: 5.4.3, 2008-10-03
xotcl-core: 0.100.1, 2009-01-23
xotcl-request-monitor: 0.40, 2007-10-14

and xotcl 1.6.1 (installed from debian package) which should fix the problem.

We have also tried xotcl-request-monitor 0.43 and xotcl library 1.6.6 to no avail (same error) we have tried reloading libraries via ns_eval with both performanceModeP on and off for the sake of testing.

any ideas or anything else to try?

Thanks in advance,

Posted by Gustaf Neumann on
Dear Raúl, i haved tried the following commands in ds/shell
   set dir [acs_root_dir]
   ns_eval source $dir/packages/acs-tcl/tcl/request-processor-procs.tcl
on the server, which comes closest to your configuration, and it works fine:
Server:    4.5.0p1 (AOLserver)
Tcl:       8.5.9
XOTcl:     1.6.6
Tdom:      0.8.3
libthread: /usr/local/aolserver/lib/thread2.6.5/
Tcllib:    /usr/local/aolserver45-HEAD/lib/tcllib1.10
acs-kernel:            2008-10-03, 5.4.3
xotcl-core:            2011-01-14, 0.118
xotcl-request-monitor: 2008-10-04, 0.42
xowiki:                2011-01-14, 0.136
xowf:                  2010-06-17, 0.30d
i would recommend XOTcl 1.6.6 and xotcl-core 0.118