Forum OpenACS Q&A: Ubuntu 12.04

Collapse
Posted by Brad Poulton on
I tried to search for this in the forums, but found no results. I wanted to let you guys know that the installation steps on the Ubuntu install page are not working. After installing on 12.04, aolserver is not listening on port 8000. I was using the 64-bit version of Ubuntu Desktop 12.04.1 in VirtualBox.
Collapse
2: Re: Ubuntu 12.04 (response to 1)
Posted by Jim Lynch on
Next steps(you will need to know where your service is stored; this is represented here as (your service):
  • Read (your service)/etc/config.tcl
  • open an additional terminal, and run:
    tail -f (your service)/log/error.log
    stop your service restart your service, and watch the tail, look for errors, look for nssock beginning to listen.
It may turn out this exploration has you locating and repairing your issue; if so, great! if not, report back.
Collapse
3: Re: Ubuntu 12.04 (response to 2)
Posted by Brad Poulton on
Here is a snippet from the error.log.

[20/Oct/2012:14:38:26][1360.1929070336][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssha1.so'
[20/Oct/2012:14:38:26][1360.1929070336][-main-] Warning: modload: could not find Ns_ModuleInit in /usr/lib/aolserver4/bin/nssha1.so
[20/Oct/2012:14:38:26][1360.1929070336][-main-] Fatal: modload: failed to load module '/usr/lib/aolserver4/bin/nssha1.so'

I verified the file nssha1.so exists. I don't know how to proceed. Thanks for the help.

Collapse
4: Re: Ubuntu 12.04 (response to 3)
Posted by Jim Lynch on
So there is a symbol (Ns_ModuleInit) which was expected by modload in nssha1.so but modload did not find it there.

I vaguely remember a similar situation where modules were built strangely (and Ns_ModuleInit was involved iirc) when aolserver 4.5 first came out; this link issue was solved in aolserver 4.5.1. It had something to do with building from each module, a nsX.so -and- a libnsX.so; I never found out why a lib was built for each module.

the only other thing I can offer, is that while I never used naviserv either before it was renamed to aolserver or after it was forked from aolserver, I'm presently trying to find out where the actice development is taking place. I may or may not switch to naviserv on that basis or on the basis of building and testing it.

-Jim

Collapse
5: Re: Ubuntu 12.04 (response to 3)
Posted by Steve Manning on
I had a very similar situation on an Ubuntu 11.10 installation a couple of weeks ago. Its as if the libnssha1.so in the aolserver/lib folder couldn't be found no matter what I did and its this lib which contains the Ns_ModuleInit.

I was running out of time so in the end, rightly or wrongly, I renamed the bin/nssha1.so and symlinked lib/libnssha1.so to bin/nssha1.so and it appears to have worked. This was just for a demo on a laptop so not a critical test but it appeared OK.

- Steve