Forum OpenACS Q&A: Re: SVC folder permissions

4: Re: SVC folder permissions (response to 3)
Posted by Matthew Coupe on
It's the tar that keeps on failing in the supervise folder on my server. I think it is the two files - 'control' and 'ok' which are giving a permission denied error, so access my whole tar file is then denied. I'm not sure if this stopped working at the same time as when I started to use SVC, my gut feeling is that it did and there was a problem with the backup server at the time of implementation so we didn't realise until now.

I have tried to tar all the files apart from the /etc/ folder for now just to get a working backup and then I will try to chown the supervise folder.

Thanks for the help Jim, much appreciated.

5: Mathew (response to 4)
Posted by Iuri Sampaio on
Maybe it's a little late to help but...

Have you tried

svgroup web /etc/service/


Sometimes, when root user start the service only it can control later.

6: Re: SVC folder permissions (response to 4)
Posted by Jim Lynch on
so you're gonna run into a few gotchas by chowning after tarring... if you're ok with experimenting, I'll let you discover some of them before posting the spoilers, then you can report back... if you're taking care of the site for another (otoh), post to let me know and I'll post some stuff... meanwhile, looking at the output of ls -lR /service/(yourOpenacs)/supervise will be a good thing to do pretty often while you're exploring.