Forum OpenACS Development: Re: Re: Installing XoWiki 0.33

Posted by Matthew Burke on
I don't think I grabbed it during the unlicky four minutes, but I tried grabbing head again, and did a clean install and it works. Well, it works more than before, but still not quite. I get the following error now when I edit pages or attempt to create new pages.

wrong # args: should be "ns_cache names cache"
while executing
"ns_cache names xowiki_cache link-*-$folder_id"
(procedure "update_references" line 17)
::xowiki::f1 ::xowiki::WikiForm->update_references
invoked from within
"my update_references"
(procedure "new_data" line 7)
::xowiki::f1 ::xowiki::WikiForm->new_data
invoked from within
"::xowiki::f1 new_data"
invoked from within
"set item_id [::xowiki::f1 new_data]"
("uplevel" body line 1)
invoked from within

Next thoughts? I've got the latest AOLserver FreeBSD package so I'm not convinced it's an obsolete nscache module, but I don't have any other ideas.


Posted by Gustaf Neumann on
This looks like an easy problem. get a recent version of ns_cache. nscache has the syntax

ns_cache names cachename ?pattern?

since a couple of ... years (?). Get a recent version of nscache

cvs -z3 co nscache

seems, as if xowiki exercises some oacs componens more than other packages....