Forum OpenACS Development: Re: building tDOM on OS X tiger

Posted by Janine Ohmer on
I cannot seem to get a tDOM library that will load on my OS X 10.4.7 laptop. Maybe someone can spot what I've done wrong.

I started out with tDOM 0.8.0, which is the current one at I have installed a more recent copy of Tcl than the one OS X comes with, so the line in my CONFIG script looks like this:

../configure --enable-threads --disable-tdomalloc --prefix=/usr/local/aolserver --with-tcl=/usr/local/lib

I made it all one line because when it's split with a continuation backslash I get these warnings when I run configure:

configure: WARNING: --prefix defaulting to TCL_PREFIX /usr/local
configure: WARNING: --exec-prefix defaulting to TCL_EXEC_PREFIX /usr/local

Putting the command all on one line gets rid of the warnings, but the built libraries still end up in /usr/local/lib/tdom0.8.0 anyway. This is a minor problem, though; it's easy enough to copy them to /usr/local/aolserver/lib/tdom0.8.0.

So moving on to building... I've tried building it with no changes, and I've also tried the changes recommended at, which is to change from building a .dylib to a .so. Same error either way; the library builds, but does not load:

[15/Sep/2006:20:03:02][10190.2684407648][-main-] Error: 0-acs-init.tcl: error loading tdom: couldn't find procedure Tdom_Init

If it makes any difference, this is an Intel-based MacBook.

Any suggestions?