Forum .LRN Q&A: Re: Problems with dotLRN 2.2.0 upgrade

Posted by Matthew Coupe on
Ok, I'm convinced that there is absolutely no way the download of dotLRN 2.2.0 from the URL works as is and without any kind of modification on Aolserver 4.0.10, postgresql 7.4.7 and Red Hat ES 4.0. I really want someone to prove me wrong!!!

I have now tried to do a clean install of this version on 2 different servers, both providing the same errors. I have also tried direct upgrades from dotLRN 2.1.1 to 2.2.0 and also this morning from a clean install of dotLRN 2.1.3 (from the download page - works a dream) to 2.2.0.

If anyone out there has managed to download this tarball as is from the download page (not cvs), install and run it and then administer classes, communities and users without enountering any problems whatsoever then I'd really like to know how!

I'm at a complete loss at how I can upgrade or even use this latest version as it does not want to work. Surely this was tested as a clean install? how can I be the only one with these problems when I can successfully run 2.1.1 and 2.1.3 without any problems? Does OpenACS 5.2.3 have additional requirements that I may have missed?

Thanks so much for any help, this is really driving me up the wall!