Forum OpenACS Q&A: Installing OpenACS 3.2.5 using RPMs

Posted by James Darwin on
Hi... I'm trying to install OpenACS 3.2.5 on Red Hat Linux 6.2. There
are the rpm file I've got:


This is the command I type:

rpm -Uvh *rpm

And, this is the error message I get:

error: failed dependencies: is needed by postgresql-7.1.2-4PGDG is needed by postgresql-7.1.2-4PGDG is needed by postgresql-libs-7.1.2-4PGDG is needed by postgresql-libs-7.1.2-4PGDG is needed by postgresql-server-7.1.2-4PGDG is needed by postgresql-server-7.1.2-4PGDG

Why am I getting these errors?

Thanks in advance.


Posted by Janine Ohmer on
Because RH 6.2 is old now, and Postgres requires newer libraries.  If possible you would be better off upgrading RedHat first;  at this point upgrading libraries is a real PITA.  Each of those probably requires five others to be upgraded, each of which will need other things upgraded, etc etc.

If you can't upgrade, you can probably compile Postgres from source without upgrading your libraries.  It's just the RPM version, which is precompiled, that requires updates.  But I haven't done this on a non-updated 6.2 in quite a while, so I can't promise you that it works!

FYI, in the future please wrap your text blocks in pre tags;  it's hard to read this way.

Posted by James Darwin on
Is it guaranteed that the RPMs will work on Red Hat Linux 7.1??? I don't mind upgrading, but I don't want to spend my time installing Red Hat Linux 7.1 and then realise that it still doesn't work.

By the way, sorry about the layout... only realised after I posted.

Posted by Janine Ohmer on
I don't know for sure which version of RH they work with - I always install from source.  Hopefully someone else will chime in here, or you could ask on one of the PG mailing lists.

My memory is a bit fuzzy on this but I think that PG 7.1.3 contained some important bug fixes, so you might want to go with that instead anyway.

Posted by Pavel Boghita on
The distribution I used was Mandrake 8.1. I've used the rpms for RedHat 7.1 and they worked very well. There is a libxml library
which may be installed easier
as part of your distribution.
Posted by Gilbert Price on
Good Afternoon,

Jonathan Marsden has posted RPMs and instructions for installing 3.2.5 under RH7.1 here. I've used his RPM's and process to install 2 heavily used systems in the past.

Good Luck...

Posted by Andrew Zeon on
I went to the same page (whichfilesdoineed.html) and simply followed the instructions for 6.2... I wonder why it doesn't work... Thanks anyway.
Posted by Gilbert Price on
I'm sorry they didn't work for you, but under 7.1 they worked like a charm for me, maybe something in your Linux install? You can try these Redhat 6.2 instructions from they are the same instructions I used for my 7.1 install and were originally written by the old Arsdigita for installing ACS and Oracle.

Or, I have some instructions at , for Red Hat 7.3, just don't do the Web Server, php or Mysql stuff. The rest of the instructions should work fine for installing either 3.2.5 or OACS 4.5.

Good Luck and if you have further questions just ask,

Posted by Lamar Owen on
Get the source RPM's and rpm --rebuild them.  Red Hat 6.2 is
virtually unsupported at this point.  That will change; but it will
be a little while.  Also be sure to get at least PostgreSQL 7.1.3.
7.1.2 has some serious bugs that 7.1.3 fixed.