Forum OpenACS Q&A: Re: Installation of OpenACS with Naviserver

Posted by Benjamin Brink on

That error usually indicates that postgresql has not been installed yet, or is not running.

For Ubuntu, to see if any postgresql packages are installed, type in terminal window:

dpkg -l | grep -i postgresql

If nothing shows up, confirm that postgresql has not been installed manually:

psql -l

If 'psql -l' results in a list of databases or an error about "role does not exist", then posgresql is installed.

If postgresql is not installed, install it using:

apt-get install postgresql-client postgresql-contrib

To see if postgresql is running:

ps auxww | grep postgresql
Posted by Juan Carlos on
I tried dpkg -l | grep -i postgresql and it showed me this list

ii libpq-dev 9.5.6-0ubuntu0.16.04 amd64 header files for libpq5 (PostgreSQL library)
ii libpq5:amd64 9.5.6-0ubuntu0.16.04 amd64 PostgreSQL C client library
ii postgresql 9.5+173 all object-relational SQL database (supported version)
ii postgresql-9.5 9.5.6-0ubuntu0.16.04 amd64 object-relational SQL database, version 9.5 server
ii postgresql-client-9.5 9.5.6-0ubuntu0.16.04 amd64 front-end programs for PostgreSQL 9.5
ii postgresql-client-common 173 all manager for multiple PostgreSQL client versions
ii postgresql-common 173 all PostgreSQL database-cluster manager
ii postgresql-contrib 9.5+173 all additional facilities for PostgreSQL (supported version)
ii postgresql-contrib-9.5 9.5.6-0ubuntu0.16.04 amd64 additional facilities for PostgreSQL

So it is installed. But when i tried psql -l It gave the same error I posted:

psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/var/pgsql_socket//.s.PGSQL.5432"?

And ps auxww | grep postgresql showed me this:

root 13775 0.0 0.1 12944 964 pts/6 S+ 17:41 0:00 grep --color=auto postgresql