Forum OpenACS Q&A: New problem: now, the site is redirecting every page to IP instead of name

Request notifications

and the problem with that, is the cert won't work with the IP address as the name. Anyone experience this?

-Jim

Here's how I can reproduce the problem:

- stop the service
- drop the database
- create an empty database
- install openacs (well, reload the data model)

After I do this, the site seems to work again... but then,

- go to site map
- set parameters of acs-kernel
- change forceHostP to 1
- click OK at bottom of page

Then the site starts redirecting

Not sure, why you want to set the parameter. Certificates are bound to a 'common name', which is usually a fully qualified domain name. Using different domain names won't work with a certificate issued for a single name. The solution is to use a multi-domain certificate [1], where one can use as well IP-addresses in the subject alternative fields [2].

When the same server receives requests under multiple names, these should be listed in the section ns/module/nssock/servers of the NaviServer config file (see also [3]).

[1] https://www.digicert.com/subject-alternative-name.htm
[2] https://cabforum.org/guidance-ip-addresses-certificates/
[3] https://naviserver.sourceforge.io/n/nssock/files/nssock.html