Forum OpenACS Development: Postgresql 9.5-9.6 Compatibility?

Request notifications

Collapse
Posted by Dave Bauer on
I checked into the compatibility matrix for a client, and they are running OpenACS 5.8.1 and their hosting provider required updating to PostgreSQL 9.5.

According to the matrix 5.8.1 is not even compatible with 9.4 but they were already running that, so I think any differences must have been fixed in their custom code.

There isn't any postgresql version in the 9.x series newer than 9.4 listed in the matrix. Does anyone know if 9.5 or 9.6 have been tested?

If they will use this code base past February 2021, I will need to devise an update strategy to the latest OpenACS and PostgreSQL versions.

Collapse
Posted by Gustaf Neumann on
There isn't any postgresql version in the 9.x series newer than 9.4 listed in the matrix.
There is PostgreSQL 11 in the matrix. "9.4" stands actually for all PostgreSQL versions from 9.4 up to 11. The matrix does not enumerate all versions, just compatibility boundaries, where e.g. some support is dropped. I am running e.g. oacs-5-10 with pg 12.2, openacs.org runs still with pg 9.6 (but also oacs-5-10).

The recommended action is to upgrade to the 5.9 series (oacs-5-9), this will provide long term stability. The upgrade from 5.8.* to 5.9 is not hard.

Compatibility in the matrix means the full spectrum, from installation, over upgrades to runtime support. If one has a running version, and is willing to rewrite update scripts, and do not care about security updates, responsive design, etc., then the old version can be used probably a long time. But if you want to upgrade then, it might be harder.

Collapse
Posted by Dave Bauer on
Thanks for the quick reply! I should have known that. I'll consult with my client, I agree they should update for security and stability.