Forum OpenACS Q&A: Updating Packages from Repository on Windows?

How does one upgrade packages on the Windows install of OpenACS?
After downloading and installing the version at
there are a number of minor things that don't work. Assuming some of the packages are out of date, I tried Upgrade From Repository at the page http://localhost:8000/acs-admin/install/.

It shows me a number of packages that can be upgraded but the upgrade fails on every package and logs these errors:

[03/Dec/2020:11:04:02][8964.3944][-conn:openacs:default:4:89-] Error: Error downloading package acs-subsite from Installing package failed.
[03/Dec/2020:11:04:02][8964.3944][-conn:openacs:default:4:89-] Notice: Installing xowiki
[03/Dec/2020:11:04:02][8964.3944][-conn:openacs:default:4:89-] Notice: - Downloading
[03/Dec/2020:11:04:02][8964.3944][-conn:openacs:default:4:89-] Notice: we can use the http::util:: interface using the curl implementation
[03/Dec/2020:11:04:12][8964.3944][-conn:openacs:default:4:89-] Notice: Unable to download. Please check your URL.

Are there some other setup steps required under Windows or is there an alternate way to upgrade packages?


Posted by Maurizio Martignano on
Dear Carl,
the only way in this distribution to safely update packages is:
1. first manually download the package(s) of interest and copy it(them) in the proper place
2. then, from ACS Admin Interface, do un upgrade from the local file system.

For example I've uploaded an experimental version of my distro at
containing the current master version of OpenACS.

Hope it helps,

Posted by Carl Lemp on
Thank you Maurizio. I did try to install the experimental version on another computer. The install worked fine but when I go to localhost:8000, I get an OpenACS Demo page with a header and just the message:
You don't have permission to read on object 606.
below the header.

I get the same message if I try to Logout or go to Your Account from the header.

I can try downloading the later versions of the packages on my other machine and see if it clears up the errors. If it does not clear them up, where is the best place to report bugs, the Bug Tracker on OpenACS?


Posted by Maurizio Martignano on
Dear Carl,
I'm sorry but I did verify also this experimental install on a clean machine and this is what I got:

If you need additional support from my side, please have a look at:

All the best,