Forum OpenACS Development: Re: OpenACS/Naviserver docker images using s6-overlay

Collapse
Posted by Gustaf Neumann on
Dear Vlad,

this sounds like a great contribution! I have tried the dockerized NaviServer version in oupfiz5/naviserver-s6:latest and it worked immediately perfectly.

On https://github.com/oupfiz5/openacs-s6 a problem with the DB port prohibited the start:

ERROR: for postgres Cannot start service postgres: Ports are not available: listen tcp 0.0.0.0:5432: bind: address already in use

Does it really conflict with the DB port in the host environment?

all the best

Collapse
Posted by Vlad V on

Gustaf, thanks.

You are right with your assumption.

The docker-compose file contains configuration parameter for postgres:

...
ports:
  - 5432:5432
...

From docs https://docs.docker.com/compose/compose-file/compose-file-v3/#ports the first value is host port. If it is busy the postgres will not run.

Probably "..address already in use for docker-compose" from https://stackoverflow.com/questions/47069540/docker-compose-postgres-5432-bind-address-already-in-use-error may become a solution ?

In near time I will modify docker-compose file that the first port value read from variable (for exclude bind address conflicts on local computer).

Collapse
Posted by Vlad V on

Done. For postgres from docker-compose specified just the container port - 5432 (an ephemeral host port is chosen for the host port).