Forum OpenACS Development: Problem installing packages with oacs-4-6 branch

Request notifications

I'm doing a new install from CVS, and the basic install went fine. After server restart, I've gone in to install some packages. When I go to package installation ( and choose one, many, or even ALL packages from the list and hit Next, I get "No packages selected" on the next page (

Any ideas? I've got a 4.5 tarball release running on port 80 of the same box with no problems. The last debug query in the log after choosing packages and hitting next is:

        update sec_session_properties
        set property_value = NULL,
          secure_p = 'f',
          last_hit = '1035857330' 
        where session_id = '2' and
          module = 'apm' and
          property_name = 'pkg_enable_list'

I've poked around in the forums a bit, and seen nothing similar to this; I've been out of the loop for awhile, though, so maybe I'm missing something obvious. Thanks for any help.

Posted by Ken Kennedy on
Ummm...ok. Never's working now, though I've done NOTHING. I was reviewing the packages-install-2.tcl file, and tried again to watch the error log...and it worked! Maybe something to do w/ caching?
Posted by Vinod Kurup on

I have seen this problem as well, but I was never able to track it down because everytime I tried to debug it, it worked. It hasn't happened to me recently, so I had thought that it was fixed, but maybe not.