Forum OpenACS Q&A: Response to Secure Vs. Insecure locations

Posted by Richard Hamilton on
Tried telnet from the Win2K box - received a 400 Bad Request with a follow up HTML page saying Invalid request - the request presented by your browser is invalid.

Tried on a Linux box within emacs, but got a connection closed after each telnet attempt so could not type the GET.

Tried from the Linux command line. Got the following text - sorry it took so long - had to type it out by hand and had problems trying to work out how to stop the HTML being rendered!!

[richard@Richard02 richard]$ su -
[root@Richard02 root]# telnet 8000
Connected to Richard02 (
Escape character is '^]'.
GET /acs-admin/ HTTP1.1

HTTP/1.0 302 Found
Set Cookie: ad_session_id=60001%2c0%20%7b928%201036018738%20257EAD4B2AD05D4D9BA6
C534DDCE9352953F65AF%7d; Path=/; Max-Age=1200
Content-Type: text/html; charset=iso-8859-1
MIME-Version: 1.0
Date: Wed, 30 Oct 2002 22:38:58 GMT
Server: AOLserver/3.3.1+ad13
Content-Length: 356
Connection: close
>!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"< >HTML> >HEAD> >TITLE>Redirection >/HEAD> >BODY> >h2>Redirection >A HREF="">The requested URL has moved here. >P ALIGN=RIGHT>AOLserver/3.3.1+ad13 on

>/BODY> Connection closed by foreign host.