Forum .LRN Q&A: dotLRN

Posted by bill kellerman on
What is the status of dotLRN for postgresql?

I installed it a few days ago to use for an online class, as it was exactly what I need.  However, only basic functionality worked without problems -- big issues especially surrounding calendaring and user accounts.

I tried branch releases of both OpenACS and dotLRN.

2: Re: dotLRN (response to 1)
Posted by Lamar Owen on
What sort of problems are you having?

I just installed the recommended OACS 4.6 CVS tag with the dotLRN 1.0 CVS tag on an UltraSPARC system (on top of PostgreSQL 7.2.4 and AOLserver 3.5.5, on Aurora SPARC Linux 0.42+updates).

I haven't run into any problems yet, but we shall see.

3: Re: dotLRN (response to 1)
Posted by bill kellerman on
All the data got screwed up, so I had to remove it.  The area where problems piled up the fastest was the calendar.

Since this is vague and not very helpful, I'm going to reinstall and make a list of the problems.  Hopefully, it will go more smoothly.

4: Re: dotLRN (response to 3)
Posted by Jeff Davis on
We are just starting the testing process for dotlrn 1.0 so I expect there will be quite a few bugs in there. The oracle side is much better tested since there are more production sites running with oracle.

If you ticket the bugs you find they should be fixed for the 1.0 release.

5: Re: dotLRN (response to 1)
Posted by bill kellerman on
Submitted bug #250.

Just in case anyone has already seen this, or I'm an idiot...

I've installed dotLRN.  Everything went fine.  Added my admin account as a user of dotLRN.

Clicked on "Create Web Log" in the Control Panel and it broke.

6: Re: dotLRN (response to 5)
Posted by bill kellerman on
Wow.  I totally looked over

That problem solved.