Forum OpenACS Q&A: Re: OpenFTS installation problems

Posted by Jose Mendez on
Did you ever resolve this problem? I am trying openfts with OpenACS 4.6 and I get the same error. I've tried different versions (0.3, 0.3.1, 0.3.2) of OpenFTS  but haven't been able to get it to initialize. I've also not been able to find the 0.31 version of OpenFTS which is supposed to be the one to use with OA 4.6 - I found OpenFTS-perl-0.31 but not the TCL version. any help will be greatly appreciated. Thanks.

Database operation "dml" failed
    while executing
"error "$err""
    invoked from within
"if [catch {
    db_dml create_table "create table $table_name ( ${table_id} int not null primary key, path varchar unique, fts_index txtidx, last_modi..."
    ("uplevel" body line 21)
    invoked from within
"uplevel {
          ad_page_contract {

    Initialize OpenFTS

    @author Neophytos Demetriou

} {
    (procedure "code::tcl::/web/captive-dev/packages/openfts-driver/www/admi..." line 2)
    invoked from within
    invoked from within
"if { [file exists $__adp_stub.tcl] } {

      # ensure that data source preparation procedure exists and is up-to-date
      adp_init tcl $__adp_stub