Forum OpenACS Q&A: Expected a 354 status line; got: 503 RCPT first


Anyone know why ns_sendmail would be failing with the above message when called by acs-mail-lite::sweeper?  This is AOLserver 3.3 ad13.

Some email messages are going out from our server.  Our email server is qmail.

Posted by Peter Marklund on
I was debugging a similar problem today. Here is what I recommend:

1) Test whether you can use ns_sendmail from a test page

2) Edit acs-mail-lite::sweeper and make the ns_log Error statement log the to, from, and subject variables. You could also try to select * from the acs_mail_lite_queue table (or similarly named) and see if there is a mail in there with a missing or invalid email address.

As it turns out acs-mail-lite::sweeper will try forever to send emails that have invalid or missing to addresses. I talked to Lars and Don today about making the sweeper give up after a number of tries.

Posted by Gilbert Price on
I had this error a while back. This thread fixed it for me:

It's line 166 in /usr/local/aolserver/modules/tcl/sendmail.tcl file.

Posted by Gilbert Price on
On second reading, this is probably not the problem. Sorry to but in, just read into your error something I wanted to see I guess...
Posted by C. R. Oldham on
You could also try to select * from the acs_mail_lite_queue table

Ah, yes, we have one entry in the queue table that has a blank "to" address. Can I just delete it with "delete from acs_mail_lite_queue where..." or do I need to do some magic pl/sql dml? (This is Oracle).

Posted by Tilmann Singer on
You propably tried it out by now anyway, but deleting from acs_mail_lite is just fine (especially given the fact that there is no pl/sql to do that).