Forum OpenACS Q&A: Newbie - Mounted Address-Book package; Nothing Works Now

Request notifications

I am having a bit of difficulty.  I just attempted to mount the address-book package (can't remember what version exactly), and it completed without errors.  But as soon as I attempt to open that resource in a browser session, I get a message that says: "The connection was refused when attempting to connect to ...".  I can go to the phsical address of the web server and it takes me to a screen called "Welcome to AOLServer".  My feeling is that the AOLServer is working properly, but the OpenACS is not.

I've attempted to restart AOLServer with the following commands:
  killall nsd
  /usr/local/aolserver/bin/nsd-postgres -t /web/service0/etc/config.tcl

This is the result of a tail on the error log.

==> /web/service0/log/error.log <==
NOTICE:  Adding missing FROM-clause entry for table "acs_object_id_seq"
NOTICE:  identifier "apm_package_version__add_interface" will be truncated to "apm_package_version__addNOTICE:  identifier "apm_package_version__add_dependency" will be truncated to "apm_package_version__ad[02/Jul/2003:09:15:34][2354.40966][-conn2-] Notice: apm_package_install_callbacks failed (probably becapgrading from 4.6.1->4.6.2, if so ignore)
[02/Jul/2003:09:15:34][2354.40966][-conn2-] Notice: the error message was: No fullquery for dbqd.acs-tcstall-procs.apm_package_install_callbacks.delete_all_callbacks and default SQL empty - query for statem[02/Jul/2003:09:15:34][2354.40966][-conn2-] Notice: APM/QD = DONE looping through files from which to l[02/Jul/2003:09:15:40][2354.8192][-main-] Notice: tclinit: re-initalizing tcl
[02/Jul/2003:09:15:40][2354.40966][-conn2-] Notice: Mounting new instance of package address-book at /aNOTICE:  identifier "apm_package__initialize_parameters" will be truncated to "apm_package__initialize_[02/Jul/2003:09:15:43][2354.8192][-main-] Notice: tcl: generating interp init script
[root@oddjob root]#

That's all I know.  I would appreciate any suggestions and help that anyone can provide.  This is frustating as heck.

Posted by Ben Koot on
Hi Garry,

Have you tried unmounting the package, delete the folder and repeat the installation process. It sometimes does the trick, although I agree it's stupid solution/

Good luck, and keep smiling


Posted by Ben Koot on

Are you trying to install the addressbook in 4.6, for postgress? you are out of luck . Check this trhread for more info


Posted by garry g on
Thanks for the quick response Ben.  What I would like to do now is to proceed with unmounting the package.  However, I cannot get into the administration page of OpenACS.  When I attempt to go to any one of these pages:
http://<my computer's ip address>:8000/admin
http://<my computer's ip address>:8000/acs-admin
http://<my computer's ip address>:8000/apm

I get the message: "The connection was refused...".  This is the only way I know of to unmount and mount packages.  Is there another way of unmounting this package?

I am using Postgres and I was unaware of it's deprication :(

Thanks in advance.

Posted by Jade Rubick on
Gary, sometimes if the package does unmount correctly, you have to it by hand. Don't worry, it's not too bad.

You go in to the command line, and type

psql -f dropfilename.sql servicename

dropfilename.sql is in the /sql/postgresql directory.

If that doesn't work, you can go even further, and open up the dropfile.sql file, and paste those commands one line at a time into a psql session.

For more current packages, you should never have to do this. Sorry you're having to deal with it now. :)

Posted by garry g on

I can't seem to find the dropfilename.sql script file.  You mentioned that it is in the /sql/postgresql directory, but can you be specific (as I've looked around for it to no avail).  And also, in the line 'psql -f dropfilename.sql servicename', I will assume that 'servicename' refers to the package name?  In my case, would that be 'address-book', or are you referring to something else.

Thank you.

Posted by Jarkko Laine on

The file is (probably) in /web/{yourserver}/packages/address-book/sql/postgresql.

The name is something like address-book-drop.sql.

If you don't find it, you can always ask for quick help at the openacs irc, #openacs at You can check the instructions how to get there from

Posted by Jarkko Laine on
oh, and the servicename means the name of your database, which is probably the same as the name of your service.

The syntax of psql is: psql {dbname}. This is everything you always have to say. Your whole site is in one database instance, so the name remains the same regardless of what package you're working on.

In this case you want to get the SQL commands from a file, so you put "-f filename.sql" inside the psql command.

Posted by garry g on
Thank you everyone for offering suggestions.  Everything is running normally again now.