Forum OpenACS Q&A: Access from behind a home firewall.

Posted by John Luong on
I am having a problem with my setup.  I had been running OpenACS 4.5 and everything was running well, but when I changed to OpenACS 4.6, everything broke.

I am running a Netgear RP114 with "virtual server" pointed at port 8000.  From the outside world, I have a regular IP address ( and locally, the machine is known as  In my AOLServer configuration, I have:

set hostname
set address

When I try to assign the hostname/address, it can't pickup the regular address (

I am assuming something has changed in OpenACS, but I am unsure.  Any tips?

Posted by Jade Rubick on
Try setting address to and restarting the server. Does that hepl?

I'm not sure what you mean by assigning the hostname and address. Is this in your logs, in your ifconfig, or where?

Posted by Gilbert Price on
I am also on a Netgear router behind a cable modem. Set your nsd.tcl to something like this (my inside lan is on

# listen on these ports
set httpport              80
set httpsport            443

# ns_info will try to guess these values based on
# your OS settings, but you may have to replace them
# with sane values if it guesses wrong!
#set hostname              [ns_info hostname]
set hostname
#set address                [ns_info address]
set address
set server              "labyrinth"
set db_name            $server
set servername          "PCS-SC Community"

Then you'll have to enable port forwarding for port 80 to your hostaddress, in my case port 80 is forwarded to . To access the webserver from inside the lan I have to use the IP address or set  to in the hosts file found in my case c:\winnt\system32\drivers\etc .

When people access your website from the Internet side with the IP assigned by the provider, the router will forward the port request to your webserver. I use TZO for Dynamic DNS and when you go to you get sent to the public, the router then forward so my internal webserver.

Hope this helps...

Posted by Don Baccus on
With my router with port forwarding enabled, when inside my LAN I have to use the local address (192.168.1.*) to hit the box and can only access via the external address from outside my LAN.

Might this be your problem?