Forum OpenACS Development: Re: ad_parameter deprecated in favor of parameter::get?

Posted by Peter Marklund on
I agree with you that the parameter name argument shouldn't have been named. In general though I've found named parameters to enhance readability, both for Tcl procs (ad_proc) and for Oracle plsql procs and functions. I believe the enhanced readability and maintainability is there not only for novices but also for experienced developers.