Forum OpenACS Q&A: openACS 4.6.3 with postgresql7.3

Request notifications

Posted by Vincent Tam on
Can openACS4.6.3 work with postgresql 7.3? I got the following error when I tried to start the aol server up with openacs.

command "ns_db" is not enabled while executing "ns_db pools" (procedure "db_bootstrap_set_db_type" line 72) invoked from within "db_bootstrap_set_db_type database_problem" AOLserver

is this because I am using postgresql 7.3, or just some error related to my installation process carelessly (i have tried installing the whole thing twice though)? I know that there was a compatibility problem with openacs4.5 and postgresql7.3, but with openacs4.6.3 documentation, it said that it can work with 7.3



Posted by Torben Brosten on
Hi Vincent,

I'm using 7.2 with 4.6.3, not 7.3, so I cannot describe how difficult it would be to use it. However, if you check the bug tracker[1], you will see that there are some bugs for openacs using 7.3 that have been fixed for Openacs5.0 (but not 4.6.3).

It seems that 7.3 is in the openacs 5.0 development wave, whereas 7.2 is used more with a matured 4.6.3 revision cycle. (Corrections by the experts appreciated.)




Posted by Joel Aufrecht on
PostGreSQL 7.3 is "officially" supported by OpenACS 4.6.3. See the compatibility matrix. So that's not the problem. It looks like the fairly fundamental command ns_db doesn't work, suggesting something in the aolserver install? Does AOLserver run without OpenACS (step 7 on this page)?
Posted by Vincent Tam on
Thanks for all replies :) I compiled nsxml again and it is working now, thanks joel for reminding me that it is something to do with ns_db rather.

But I got another problem now, whenever I submit something (eg. login/logout), i got a "page not found" error from the browser. but the submitted value does pass to the system. (therefore when i login, even though i got a page not found, when i go back to the root, i am being logged in). After investigation, I discover that it is a problem to do with ad_returnredirect. i have tried to

ad_returnredirect /

and it brings me to something else. i discovered that this tcl function will invoke [util_current_location]. i therefore printed the value of it, and find that [util_current_location] contains only the first half of my base_url. i guess it is because i have set my base url wrongly in some step during installation. Any hints how to deal with it?

Posted by Vincent Tam on
to be specific, I am using virtual host. my base url and setting in starting up the aolserver is as followed:


set hostname username.srvr.domain
set address
set httpport 80
set httpsport 443

ad_returnredirect /
somehow brings me to username.srvr
instead of the base url

Posted by Jade Rubick on