Forum .LRN Q&A: How to set kelp-theme by default

Request notifications

Posted by Felix Paco on
Hi all,

I have a little problem. I'm not able to set the kelp-theme by default for the hole site in dotLRN. With the help of Developer tool I see that in the main menu still appear the zen-theme because it is getting /var/www/dotlrn-2.3.0/packages/theme-zen/lib/lrn-master and /var/www/dotlrn-2.3.0/packages/theme-zen/lib/layouts/zen2 for the main portal of courses, communities, control panel and administration. And when I get inside a course or a community the theme kelp appears correctly. I change every parameters concern with default themes in dotLRN, but I still get the problem.

Can anyone help me setting up by default the theme kelp for the hole site?

Thank you in advance.

Posted by Emmanuelle Raffenne on
You can check 2 things here:

- In the dotlrn administration (Administration tab), go to "Site template" then "Admin parameters for site templating". Make sure the kelp theme is selected in all cases and the master template is set to the kelp one.

- In the OpenACS site-wide administration, check that the parameter "DefaultMaster" of the Main site is set to the kelp one.

Posted by Felix Paco on
Hi Emmanuelle,

I solve the problem. As you mentioned above the DefaultMaster parameter it was not set with the value of the kelp theme.

Thank you.