Forum OpenACS Development: Re: content_folder.rename

16: Re: content_folder.rename (response to 1)
Posted by Don Baccus on
If you look at the link provided above you'll see that we did settle on the p_* and v_* notation. I guess that never got migrated to our docs.

The problem we face (as always) is legacy code, there are lots of queries out there using named parameters ("param_name => value") in calls to PL/SQL and breaking them is something we were loath to do, given that we knew some folks would be migrated aD 4.2 sites to OpenACS 4 etc.

For new stuff though I'd love to see us settle on that convention if others agree. Do we have something like consensus among those posting to this thread? If so, let's TIP it.

Posted by Dirk Gomez on
I am sure that we will find a way to get rid of as many bad examples as possible. Because bad code breeds bad code we should always work eagerly towards this goal :)

It should be possible to "script"-ize at least parts of such a conversion. I will dig up the sed book.

Otherwise I agree: let's get rid of a prefixed variables at least for all new packages.

Posted by Tom Jackson on

Yes, I agree. I thought that was the convention. Everytime I have to look at old code I get confused by the var names. There isn't much to do about old code, but new stuff probably would be much easier to understand and maintain by following these two simple conventions.