Forum OpenACS Development: Re: Remaining work for 5.0.0 release

Posted by Peter Marklund on
I just wanted to brief people on what is involved in bringing translations on the translation server over to the 5.0 branch:

1. First we need to fix the broken acs-lang upgrade test case on the Oracle test server. My suspicion is that the cause of the failure is a violation of the lang_messages_audit_pk constraint which is on (package_key, message_key, locale, overwrite_date). I suppose it is the overwrite_date that is identical for two inserts although I would have thought that sysdate would be granular enough for this not to happen. A fix would be to make lang_messages_audit use an integer primary key instead. Making this change should be straightforward and shouldn't be more than 1 work day.

2. Merge the latest message catalog files on the 5.0 branch with the translations on the translation server. This involves importing the 5.0 catalog files to the translation server, resolve any conflicts in the acs-lang admin UI, and then export the result and commit it on the 5.0 branch. After that we should run my catalog consistency check script on the 5.0 branch and see if any keys should be removed or are missing. I think it's best if I do this and I think we're looking at another work day.

Posted by Joel Aufrecht on
Based on the last OCT discussion, I think we are ready to release 5.0 RC1. I tidied up the (still incomplete) upgrade instructions. In addition to upgrade code and docs being very preliminary, I still haven't dealt with all of the doc bugs and errata. Anyway, I went to build the RC, following these instructions, and got:
[joela@samoyed joela]$ cd /var/tmp
[joela@samoyed tmp]$ cvs -d /cvsroot checkout -r oacs-5-0 openacs-4
cvs checkout: in directory openacs-4:
cvs [checkout aborted]: *PANIC* administration files missing
[joela@samoyed tmp]$
Posted by Jeff Davis on
Checkout worked for me (although there were some files owned
by the web group rather than the cvs group which I fixed).
See if it works now.
Posted by Joel Aufrecht on
That fixed the OpenACS cvs error, so I went ahead and made the tarball. I've posted it on the front page in addition to beta 4; once I test it and get some feedback, i'll take down Beta 4.

I hit this error for dotlrn, so I didn't make dotLRN 2 RC1:

[joela@samoyed dotlrn-packages]$ cvs -d /dotlrn-cvsroot checkout -r dotlrn-2-0 dotlrn-all
cvs checkout: Updating bboard-portlet
cvs checkout: failed to create lock directory for `/dotlrn-cvsroot/bboard-portlet' (/dotlrn-cvsroot/bboard-portlet/#cvs.lock): Permission denied
cvs checkout: failed to obtain dir lock in repository `/dotlrn-cvsroot/bboard-portlet'
cvs [checkout aborted]: read lock failed - giving up
Posted by Jade Rubick on
Does the OpenACS core team have a policy on upgrades with release candidates? If there was a policy of supporting upgrades to and from release candidates, that might encourage more people to try the release candidates.