Forum OpenACS Q&A: Installation failure at tDOM make

Posted by Andre Dubuc on
I installed the aolserver, and then proceeded to install tDOM. In the CONFIG file I edited it to read:

../configure --enable-threads --disable-tdomalloc \
--with-aolserver=$aolsrc \

Compiling tDOM-0.7.8 for OpenACS 5.0.0rc1, I get the following error message on make:

"In file included from ../generic/xmlsimple.c:69
../generic/dom.h:487: error: parse error before "Tcl_Obj"
. . .
[many more lines of error]

Apparently from an earlier configure warning, tDOM complained that although --enable-threads were enabled, they weren't. Now, this version calls upon the built-in version of tcl8.3.2, so my question: is there a bug is this program?

Assuming that the problem might be a conflict with the present Mandrake 9.1 distro tcl/tk version installed in /usr/lib, I d/l another tar.gz copy of tcl8.3.2 and installed it in /usr/local/src (with --enable-threads of course). Did a make clean, and re-ran -- same error.

Then I replaced tcl8.3.2 found in the aolserver/aolserver/ dir with my new compiled version. This time no configuration warning about threads not being enabled, but still no change in the error message. I've run out of ideas on how to fix this problem. Any ideas what I can do next?

Btw, the prog looks really great -- an d I can't wait to try it out.


Posted by Torben Brosten on

Are you using Aolserver 4.0?

tcl 8.4.x is required[1] for aolserver 4.0.


Posted by Andre Dubuc on
Hi Torben,

No, I'm using aolserver3.3oacs1. The 'Individual Programs' requirement page for OpenACS5.0.0rc1 suggested that one.

Would 4.0 be better? Would it work
with openacs 5.0?


Posted by Cathy Sarisky on
If you haven't already, you might want to 'make clean' and make sure you don't have a unix/config.cache file in your tDOM source directory.  I had a major hair-pulling experience after my first compilation attempt failed (some path set wrong) that turned out to be a problem with the original (wrong) settings hanging around in config.cache.
Posted by Andre Dubuc on
Thanks Cathy,

First stop in resoloving this problem was your thread of Dec 20th (and the irc.log) Thanks!. I have dumped and untarred a few times, to no avail.

After one attempt of  'sh CONFIG', I received a warning message, that indeed --enable-threads had been requested, but the request failed. What I 'd like to know -- if tcl8.3 has previously been set up on /usr/lib by the distro setup, and tcl8.3 in one of the aolserver/aolserver dirs, why is this not working? I even installled a fresh thread-enabled tcl8.3.2 in its own dir and then tried it in the aolserver dir. No go.

I have 'blown' away the unix/config.cache by deleting the /usr/local/src entries (which includes the aolserver/tDOM).

Is this gonna be one of those 'nice-to-watch-others-use' type of programs, or is there a solution?

Any ideas? Is it possible to override some config details that will get tDOM to work?


Posted by Cathy Sarisky on
Hey Andre,

Post the results of your sh CONFIG ?

I'm especially interested to know what it says for
"checking for Tcl configuration... "


Posted by Andre Dubuc on
Hi Cathy,

Well in the meantime, I figured it out. I examined the output precisely where you were suggesting:

checking for Tcl configuration... found /usr/local/src/aolserver/aolserver/tcl8.3.2/unix/
checking for existence of /usr/local/src/aolserver/aolserver/tcl8.3.2/unix/ loading
configure: warning: --prefix defaulting to TCL_PREFIX /usr/local
configure: warning: --exec-prefix defaulting to TCL_EXEC_PREFIX /usr/local

Now that didn't seem right. So, I wandered into /usr/local/src/aolserver/aolserver/tcl8.3.2/unix
and modified:


As a precaution, I deleted the config-cache as well, and ran 'make' on tDOM-0.7.8/unix.

No errors, so I hope the thing did it's thing OK.

Thanks for the help. Now on to the next step . . .