Forum OpenACS Q&A: Can't connect to Aolserver/ACS-host not found

I've installed Aolserver, Postgres, Postgres driver, and ACS. I've gotten to the point where I should be able to connect to with Lynx (by typing "lynx")and open up the /web/server1/www/index.tcl page. However, Lynx spends some time looking for the server and then quits saying that it can't find the host. It does return the source a redirect page (this looks like an aolserver generated page, although I have been unable to find the page on my system). I've also noticed an error in my server log with a strange url, something like

I've followed a few suggestions I found on the forum, such as adding a "auxconfigdir /web/${server}/parameters" to the parameters section of the nsd.tcl file and changing enabletclpages to true. I've also added " server1" to my /etc/hosts file and made the symbolic link necessary for the postgres driver to work (I can't remember the name of the link right now).

Does anyone know why I can't connect to ACS? I've done a ps aux and the aolserver is up and running.

My nsd.tcl page is here.

Either grep or edit your server log (generally in /home/aolserver/log) and look for the word "Error."  Generally it's next to something like "Unable to bind to port 80," or some such.  While the nsd daemon is running, it's probably not doing anything useful.  If the port 80 is the problem, try starting nsd from root.
Don't worry about the webrobot link not working; it's looking for an external (internet) address and you are operating locally, but this won't stop ACS.
you have obviously looked at the server logs  - I find them very useful & suggest deleting the log then restarting nsd (to get a single load log) and scanning the log. You can see how ACS sets itself up, and spot any problems. Any event labelled "fatal" is usually that!

If you want to test it and can't run as root, setting the port to 8000  restarting nsd and logging in as localhost:8000 should work OK.

The locations of the error pages are defined in the "ad.ini" (your "compdb.ini"?) in the parameters directory under /web/{servername}.

Thanks for the responses, I think I may have made the change to make it work. I changed both the hostname and address to in the nsd.tcl and changed the entry in /etc/hosts to " server1". I can now connect by typing "lynx server1". The first page that comes up is the register page, is that correct?

Also, I do not have X installed, so Lynx is my only browser at the moment. Is Lynx supposed to work with OpenACS. Lynx does store cookies, but I keep getting thrown back to the registration page.