Forum OpenACS Q&A: New OpenACS 5.1 install, but a problem occurs

Request notifications

I've been playing around with OpenACS 5.1.0 for a couple of days, and from I've seen so far, I LOVE IT!  I'm still unsure on some of the terminology and how things integrate, but the raw power and usability right "out of the box" is great.

Two things:
1) Is there a mirror somewhere of <>? The site appears to be gone, and I'm trying to find some "baby steps" help in using OpenACS.

2) My portrait doesn't display in my profile.  It says that it's been uploaded, but it doesn't display on my screen.  It looks like my web browser sets aside space for the image (based on the image's dimensions), but nothing appears on the screen, and then the screen redraws to eliminate all of the white space.

Any ideas?

My system is:
Redhat 6.2
Postgresql 7.3.4
Aolserver 4.0.1
OpenACS 5.1.0 (downloaded as tarball)


Posted by Chris Davies on
not sure on the first issue.

However, the user portrait has a few parameters you might want to check.  I think there is a maximum size, and I think there are maximum width/height restrictions.  It appears the width must be less than 300.

Might want to play around with that to start with.

Posted by Peter Lim on
Thanks for the hints on the portrait size, but it's still no-go.  I've tried tiny gifs, large jpegs (larger than the 300 pixel max), and various images in between.  I tried uploading a photoshop file (just to see what would happen), and it gave me an error that it was the wrong mime type, so it appears that the file is getting uploaded, but I don't know what's wrong after that.  There are no errors appearing in the log, either.

When I look at the page information (in Netscape), it has the right dimensions of the image, but it lists the physical dimensions of the image as 0px height and 0px width.

I'm trying to track down in the database/CR where the image is stored so that I can try checking that to see if that is correct, but I'm having difficulty tracing back through the queries and the code.

And I was able to get the photo-album working properly, so that part of the photo upload and display works properly, but not in the user portraits.

Posted by Jeff Davis on
I fixed a bug for portrait upload which should fix this I think see

the fix will be in 5.1.1 (or you could try making that
change locally to see if thats it or if it's something else).

Posted by Peter Lim on
That worked for the user portraits!  Thanks!