Forum OpenACS Q&A: installation woes

Request notifications

Posted by brad babai on
2 questions

im installing dotlrn onto my laptop, now i have postgre and aolserver running, but atm when im following the installation guide given (the openacs 5.0.4 install guide) as im using a laptop which will get a new IP address every time, does this mean i have to install manually?

also when i try to install manually, i get an error after loggin in as "service0" when i try to go to /var/lib/aolserver i get permisssion denied even though i have don chmod 770 to the directory, by changing the chmod to 775 i then tried to untar dotlrn from /tmp but it also said i couldnt.

what am i doing wrong?????

2: Re: installation woes (response to 1)
Posted by Torben Brosten on

When a server is run from a laptop/desktop with a dynamic ip, I believe you can still use http://localhost:port/ to access the server from your laptop.  When you know the dynamic IP address, then you can temporarily access the server from other computers --but it is generally awkward to access a server with a dynamic ip.

regarding permission denied, try this:

login as root
root# cd /var/lib
root# chmod -R 770 aolserver
root# cd /var/lib/aolserver
root# chown -R service0:web service0

This page may have more useful info:

also you might have to be logged in as root to access /tmp and untar files

hope this helps,


3: Re: installation woes (response to 2)
Posted by brad babai on
thanks for the help, im almost done now, but ive hit this other snag which is a bit baffling to me

in step 5 of the openacs install guide i run the program using

/usr/local/aolserver/bin/nsd-postgres -t /var/lib/aolserver/weg/etc/config.tcl  (ive changed service0 to weg)

i get the right output on my xterm console but when i type into the browser http://weg.test:8000 i get a cannot connect error

my error log seems fine except for to error readings which are

[05/Aug/2004:17:44:59][3344.1075081856][-main-] Error: pidfile: failed to open pid file '/usr/local/aolserver/log/nspid.weg': 'Permission denied'

[05/Aug/2004:17:44:59][3344.1075081856][-main-] Fatal: modload: failed to load module '/usr/local/aolserver/bin/'

Fatal: modload: failed to load module '/usr/local/aolserver/bin/'

Is there any explanation for this?  the first error is weird because when i go to that directory path, the nspid.weg doesnt exist....

neither does the file,

4: Re: installation woes (response to 1)
Posted by Torben Brosten on
Hi Brad,

since is not there, you need to install it. nssha1 is an aolserver module. install directions are here:

"when i go to (/usr/local/aolserver40r5/log), the nspid.weg doesnt exist...."

aolserver is trying to write a file there. That makes this a permissions issue.

The top of the install openacs5.1 page[1] shows how to set it. I recall having difficulty myself with getting chgrp "stick" at times. You need to give permission to the web group to access this area.

try this, as user root:

cd /usr/local/aolserver40r5
chmod -R root:web log
chmod -R root:web servers

you might need to give the "web" group permission to the entire dir:

chmod -R root:web /usr/local/aolserver40r5


5: Re: installation woes (response to 1)
Posted by brad babai on
i did as you said and changed the permissions and now im getting an error message saying
  Ns_Tls: invalid key: 0: should be between 1 and 100

as output on my console whenever i try to sartup the server with
/usr/local/aolserver/bin/nsd-postgres -t /var/lib/......

6: Re: installation woes (response to 1)
Posted by Torben Brosten on
That's a new one for me, Brad. Sorry I can't help.

You'll find that knowledgeable forum subscribers will help when the problem is stated with as much detail as might be needed to solve it; and especially when a problem statement includes credible evidence that attempts have been made to solve the problem independently. For example, describing attempted fixes.

You might try what I and others do in this situation: google for whatever error statement you get. Google's advanced search feature helps to narrow a search to web content related to others who have had similar problems and how it is solved.

good luck!


7: Re: installation woes (response to 1)
Posted by xx xx on
Probably, the hostname cannot be resolved to any proper IP address. Fix your config.tcl or try the fix in Aolserver 4.07. I've seen it happen on my notebook.