Forum OpenACS Q&A: Re: Pgadmin III

3: Re: Pgadmin III (response to 1)
Posted by Patrick Giagnocavo on
What is happening is that the Postgres server is listening on a local unix socket (sometimes called a domain socket), rather than on a network-accessible TCP/IP socket.  Thus, you cannot connect to the server over TCP/IP .

Be sure that you start your PG server process with -i , so that it listens on both TCP/IP and the local unix socket.

4: Re: Pgadmin III (response to 3)
Posted by Boris Kruvshenko on
Hi Patrick, I have postgres 7.4.5, and it starts the postgres with pg_ctl as:

su - postgres -c "/usr/local/pgsql/bin/pg_ctl start -D '/usr/local/pgsql/data' -s -l /usr/local/pgsql/data/server.log"

but it doesn´t recognice the -i option... so ????

5: Re: Pgadmin III (response to 4)
Posted by Steve Manning on
No offence Patrick but the -i option is the old way of doing it ;o) now you just change a setting.

Look for the postgresql.conf file in the pg data directory and inside there change the line tcpip_socket = true.

  - Steve

6: Re: Pgadmin III (response to 5)
Posted by Boris Kruvshenko on
Thx Steve, it works changing the postgresql.conf.